[백준] 알파벳 (java) Dfs

2020-03-10

알파벳 (백준> Dfs_Bfs)

문제 링크

문제설명

세로 R칸, 가로 C칸으로 된 표 모양의 보드가 있다. 보드의 각 칸에는 대문자 알파벳이 하나씩 적혀 있고, 좌측 상단 칸 (1행 1열) 에는 말이 놓여 있다.

말은 상하좌우로 인접한 네 칸 중의 한 칸으로 이동할 수 있는데, 새로 이동한 칸에 적혀 있는 알파벳은 지금까지 지나온 모든 칸에 적혀 있는 알파벳과는 달라야 한다. 즉, 같은 알파벳이 적힌 칸을 두 번 지날 수 없다.

좌측 상단에서 시작해서, 말이 최대한 몇 칸을 지날 수 있는지를 구하는 프로그램을 작성하시오. 말이 지나는 칸은 좌측 상단의 칸도 포함된다.

입력

첫째 줄에 R과 C가 빈칸을 사이에 두고 주어진다. (1<=R,C<=20) 둘째 줄부터 R개의 줄에 걸쳐서 보드에 적혀 있는 C개의 대문자 알파벳들이 빈칸 없이 주어진다.

출력

첫째 줄에 말이 지날 수 있는 최대의 칸 수를 출력한다.

예제 입력 1 복사

2 4
CAAB
ADCB

예제 출력 1 복사

3


풀이

import java.util.*;

public class Main {

	static int arr[][];
	static boolean alpa[] = new boolean[26];	 //A=0, B=1, C=2 ...
	static int answer= 1;
	static int count = 1;
	
    public static int[] dy = {-1, 1, 0, 0}; // 상하 좌우;
    public static int[] dx = {0, 0, -1, 1};
	
    
    public static int step = 1;
    public static int max_step = 1;
    
    public static void dfs(int x, int y) {
        int alpha = arr[x][y];
        alpa[alpha] = true;
        
        for(int i=0; i < 4; i++) {
            int xx = dy[i] + x;
            int yy = dx[i] + y;
            
            if(xx >= 0 && yy >= 0 && xx < arr.length && yy < arr[0].length && !alpa[arr[xx][yy]]) {
	            max_step = Math.max(max_step, ++step);    
	            dfs(xx, yy);
	        }
            
        }//for
        
        // 여기서 초기화 하지 않으면 다른 경로에서 접근 할 수 없다.
        step --;
        alpa[alpha] = false;
    }
	
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		
		int r = sc.nextInt();
		int c = sc.nextInt();
		
		sc.nextLine();
		
		arr = new int[r][c];
		
		for(int i=0; i<r; i++) {
			String s = sc.nextLine();
			for(int j=0; j<c; j++) {
				arr[i][j] = s.charAt(j)-65;
			}
		}
		
		dfs(0,0);
		
		System.out.println(max_step);
	}
}

후기 (1h)

난 분명히 넣는 것도 제대로 넣고, 다 했는데 왜…? 같은코드 인 것 같은데 왜때문에 안된다구요….? 밑에 코드랑 차이점 아는 분 설명해주세오….

+왜 난 점점 dfs를 풀면 풀 수록 멍청이가 되어가는 것 같지…? 정신차려잇


package Dfs_Bfs;

import java.util.*;

public class beak_알파벳 {

	static int arr[][];
	static boolean alpa[] = new boolean[26];	 //A=0, B=1, C=2 ...
	static int answer= 1;
	static int count = 1;
	
	static void dfs(int i, int j) {
		int c = arr[i][j];
		alpa[c] = true; //방문했으니까 1로바꿔줌
		
		int dx[] = {0, 0, 1, -1};
		int dy[] = {1,-1, 0, 0};
		
		for(int k=0;i<4;i++) {
			int x = i + dx[k];
			int y = j + dy[k];
			
			if(x>=0 && x<arr.length && y>=0&& y<arr[0].length && !alpa[arr[x][y]]) {
				answer = Math.max(answer, ++count);
				dfs(x,y);
			}
		}
		
		//갔다 나왔으면 cnt--해주고, visited도 false로 만들어 줘야 다음으로 갈 수 있다.
		count--;
		alpa[c] = false;
		
	}
	
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		
		int r = sc.nextInt();
		int c = sc.nextInt();
		
		sc.nextLine();
		
		arr = new int[r][c];
		
		for(int i=0; i<r; i++) {
			String s = sc.nextLine();
			for(int j=0; j<c; j++) {
				arr[i][j] = s.charAt(j)-65;
			}
		}
		
		dfs(0,0);
		
		System.out.println(answer);
	}
}