[백준] N과 M (8) (java) 조합, Combination, 중복 O, 응용ver

2020-03-31

N과 M (8) (백준> Math / 조합, Combination, 중복 O, 응용ver)

문제 링크

문제설명

N개의 자연수와 자연수 M이 주어졌을 때, 아래 조건을 만족하는 길이가 M인 수열을 모두 구하는 프로그램을 작성하시오. N개의 자연수는 모두 다른 수이다.

  • N개의 자연수 중에서 M개를 고른 수열
  • 같은 수를 여러 번 골라도 된다.
  • 고른 수열은 비내림차순이어야 한다

예제

//입력
3 1
4 5 2

//출력
2
4
5

예제

//입력
4 2
9 8 7 1

//출력
1 1
1 7
1 8
1 9
7 7
7 8
7 9
8 8
8 9
9 9


풀이

package Math;

import java.util.Arrays;
import java.util.LinkedList;
import java.util.Scanner;

public class beak_NM_8 {

	static int n;
	static int m;
	static LinkedList<Integer> result;
	static StringBuilder sb;
	static LinkedList<Integer> numbers;
	
	public static void perm(int count) {
		if(count == m) {
			for(int i:result)
				sb.append(i + " ");
			
			sb.append("\n");
			return ;
		}
		
		for(int i=0; i<n; i++) {
			
			//result가 가진 끝값의 number인덱스가 i이상이어야 한다.
			if(result.size() !=0 && i <numbers.indexOf(result.getLast()))
				continue;
			
			result.add(numbers.get(i));
			perm(count+1);
			result.removeLast();
		}
	}
	
	
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		
		n = sc.nextInt();
		m = sc.nextInt();
		
		sb = new StringBuilder();
		numbers = new LinkedList<>();
		result = new LinkedList<>();
		
		for(int i=0; i<n; i++)
			numbers.add(sc.nextInt());
		
		numbers.sort(null);
		
		perm(0);
		
		System.out.println(sb.toString());
	}
}


후기 (20min)

푸는 방식은 (6)과 비슷하다.

numbers가 가지는 마지막 값의 인덱스보다 i가 작은 경우에만 continue라는건,

크거나 같으면 add 해준다는거니까 중복을 만들 수 있다.

	if(result.size()!=0 && i < numbers.indexOf(result.getLast()))
				continue;
Read More

[백준] N과 M (7) (java) 순열, Permutation, 중복 O, 응용ver

2020-03-31

N과 M (7) (백준> Math / 순열, Permutation, 중복 O, 응용ver)

문제 링크

문제설명

N개의 자연수와 자연수 M이 주어졌을 때, 아래 조건을 만족하는 길이가 M인 수열을 모두 구하는 프로그램을 작성하시오. N개의 자연수는 모두 다른 수이다.

  • N개의 자연수 중에서 M개를 고른 수열
  • 같은 수를 여러 번 골라도 된다.

예제

//입력
3 1
4 5 2

//출력
2
4
5

예제

//입력
4 2
9 8 7 1

//출력
1 1
1 7
1 8
1 9
7 1
7 7
7 8
7 9
8 1
8 7
8 8
8 9
9 1
9 7
9 8
9 9


풀이

package Math;

import java.util.Arrays;
import java.util.LinkedList;
import java.util.Scanner;

public class beak_NM_7 {

	static int n;
	static int m;
	static LinkedList<Integer> result;
	static StringBuilder sb;
	static LinkedList<Integer> numbers;
	
	public static void perm(int count) {
		if(count == m) {
			for(int i:result)
				sb.append(i + " ");
			
			sb.append("\n");
			return ;
		}
		
		for(int i=0; i<n; i++) {
			result.add(numbers.get(i));
			perm(count+1);
			result.removeLast();
		}
	}
	
	
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		
		n = sc.nextInt();
		m = sc.nextInt();
		
		sb = new StringBuilder();
		numbers = new LinkedList<>();
		result = new LinkedList<>();
		
		for(int i=0; i<n; i++)
			numbers.add(sc.nextInt());
		
		numbers.sort(null);
		
		perm(0);
		
		System.out.println(sb.toString());
	}
}


후기 (20min)

푸는 방법은 (5)와 같으며 중복을 허용하기 때문에, 중복을 제거하는 if문만 빼주면 된다.

Read More

[백준] N과 M (6) (java) 조합, Combination, 중복 X, 응용ver

2020-03-31

N과 M (6) (백준> Math / 조합, Combination, 중복 X, 응용ver)

문제 링크

문제설명

N개의 자연수와 자연수 M이 주어졌을 때, 아래 조건을 만족하는 길이가 M인 수열을 모두 구하는 프로그램을 작성하시오. N개의 자연수는 모두 다른 수이다.

  • N개의 자연수 중에서 M개를 고른 수열
  • 고른 수열은 오름차순이어야 한다.

예제

//입력
3 1
4 5 2

//출력
2
4
5

예제

//입력
4 2
9 8 7 1

//출력
1 7
1 8
1 9
7 8
7 9
8 9


풀이

package Math;

import java.util.Arrays;
import java.util.LinkedList;
import java.util.Scanner;

public class beak_NM_6 {

	static int n;
	static int m;
	static LinkedList<Integer> result;
	static StringBuilder sb;
	static LinkedList<Integer> numbers;
	
	public static void comb(int count) {
		if(count == m) {
			for(int i:result)
				sb.append(i + " ");
			
			sb.append("\n");
			return ;
		}
		
		for(int i=0; i<n; i++) {
			if(result.contains(numbers.get(i)))
				continue;
			
			//result가 가진 끝값의 number인덱스가 i이상이어야 한다.            
			if(result.size()!=0 && i < numbers.indexOf(result.getLast()))
				continue;
			
			result.add(numbers.get(i));
			comb(count+1);
			result.removeLast();
			
		}
	}
	
	
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		
		n = sc.nextInt();
		m = sc.nextInt();
		
		sb = new StringBuilder();
		numbers = new LinkedList<>();
		result = new LinkedList<>();
		
		for(int i=0; i<n; i++)
			numbers.add(sc.nextInt());
		
		numbers.sort(null);
		
		comb(0);
		
		System.out.println(sb.toString());
	}
}

후기 (20min)

푸는 방식은 (5)와 비슷하다.

다만, 1,2,3 순차적으로 들어오는 것이 아니기때문에 리스트로 numbers에 값을 받고

중복을 허용하지 않기위해서

		if(result.contains(numbers.get(i)))
			continue;

를 추가해주고,

numbers가 가지는 마지막 값보다는 i가 커야하기때문에 (어차피 같다는 위에서 걸러줌) 조건 추가

	if(result.size()!=0 && i < numbers.indexOf(result.getLast()))
				continue;
Read More

[백준] N과 M (5) (java) 순열, Permutation, 중복 X, 응용ver

2020-03-31

N과 M (5) (백준> Math / 순열, Permutation, 중복 X, 응용ver)

문제 링크

문제설명

N개의 자연수와 자연수 M이 주어졌을 때, 아래 조건을 만족하는 길이가 M인 수열을 모두 구하는 프로그램을 작성하시오. N개의 자연수는 모두 다른 수이다.

  • N개의 자연수 중에서 M개를 고른 수열

예제

//입력
3 1
4 5 2

//출력
2
4
5

예제

//입력
4 2
9 8 7 1

//출력
1 7
1 8
1 9
7 1
7 8
7 9
8 1
8 7
8 9
9 1
9 7
9 8


풀이

package Math;

import java.util.*;

public class beak_NM_5 {

	static int n;
	static int m;
	static LinkedList<Integer> result;
	static StringBuilder sb;
	static LinkedList<Integer> numbers;
	
	public static void perm(int count) {
		if(count == m) {
			for(int i: result)
				sb.append(i + " ");
			
			sb.append("\n");
			return;
		}
		
		for(int i=0; i<n; i++) {
			if(result.contains(numbers.get(i)))
				continue;
			
			result.add(numbers.get(i));
			perm(count+1);
			result.removeLast();
		}
	}
	
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		
		n = sc.nextInt();
		m = sc.nextInt();
		
		sb = new StringBuilder();
		numbers = new LinkedList<>();
		result = new LinkedList<>();
		
		for(int i=0; i<n; i++)
			numbers.add(sc.nextInt());
		
		numbers.sort(null);
		
		perm(0);
		
		System.out.println(sb.toString());
	}
	
}

후기 (20min)

푸는 방식은 (3)과 똑같다.

다만, 1,2,3 순차적으로 들어오는 것이 아니기때문에 리스트로 numbers에 값을 받고

중복을 허용하지 않기위해서

		if(result.contains(numbers.get(i)))
			continue;

를 추가해주고,

숫자를 넣을때는 numbers에 들어있는 숫자를 result에 넣는다

Read More

[백준] N과 M (4) (java) 조합, Combination, 중복 O

2020-03-31

N과 M (4) (백준> Math / 조합, Combination, 중복 O)

문제 링크

문제설명

자연수 N과 M이 주어졌을 때, 아래 조건을 만족하는 길이가 M인 수열을 모두 구하는 프로그램을 작성하시오.

첫째 줄에 자연수 N과 M이 주어진다. (1 ≤ M ≤ N ≤ 8)

  • 1부터 N까지 자연수 중에서 M개를 고른 수열
  • 같은 수를 여러 번 골라도 된다.
  • 고른 수열은 비내림차순이어야 한다

출력

한 줄에 하나씩 문제의 조건을 만족하는 수열을 출력한다. 중복되는 수열을 여러 번 출력하면 안되며, 각 수열은 공백으로 구분해서 출력해야 한다.

수열은 사전 순으로 증가하는 순서로 출력해야 한다.

예제 입력 1 복사

3 1

예제 출력 1 복사

1
2
3

예제 입력 2 복사

4 2

예제 출력 2 복사

1 1
1 2
1 3
1 4
2 2
2 3
2 4
3 3
3 4
4 4

풀이

package Math;

import java.util.*;


//조합 (중복 O)
public class beak_NM_4 {
	static int n;
	static int m;
	static StringBuilder sb;
	static LinkedList<Integer> numbers;
	//nCm
	public static void comb(int count) {
		if(count == m) {
			for(int i:numbers)
				sb.append(i + " ");
			sb.append("\n");
			
			return;
		}
		
		for(int i=0; i<n; i++) {
            //중복을 위해서는 자기 자신도 돌아야 하기때문에 -1
			if(numbers.size() !=0 && i<numbers.getLast()-1)
				continue;
			
			numbers.add(i+1);
			comb(count+1);
			numbers.removeLast();
		}
		
	}
	
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		
		n = sc.nextInt();
		m = sc.nextInt();
		
		numbers = new LinkedList<>();
		sb = new StringBuilder();
		
		comb(0);
		
		System.out.print(sb.toString());
		
	}
}

후기 (20min)

중복을 허용하는 조합은

if(numbers.contains(i+1)) continue 라는 조건을 빼고,

자기자신도 갔다와야 하기 때문에 i<numbers.getLast()-1을 걸어준다!

Read More